Skip to Content

IT nieuczesane.
archive

> Daily Archives: 21 kwietnia 2010

SharePoint nie pyta czy edytować dokument

Taki dziwny objaw: podczas otwierania pliq SP nie zadaje pytania czy plik ma być do edycji czy do odczytu – po prostu go otwiera. za chwilę oczywiście pokazuje się komunikat informujący, że plik jest tylko do odczytu i naciśnij guzik aby go edytować

wsserr01 

obrazek jest dla excela ale ten sam objaw jest dla czegokolwiek. po naciśnięciu ‘edit’ pojawia się ‘spadaj szczawiu’:

wsserr02

po długim googlaniu i bezefektywnych próbach wdrożenia najdziwniejszych konfiguracji w końcu udało mi się ustalić, któryż to z moich najulubieńszych programów jest winny – jak zwykle jest to IE. przez tyle lat i na prawdę ogarnięcie zasad działania tej aplikacji pozostaje dla mnie niemożliwe. rozwiązaniem jest… usunięcie site’u z ‘Trusted Sites’

wsserr03

nie chce mi się spędzać czasu nad netmonem i innymi wynalazkami, żeby dojść *czemu* tak się dzieje… ważne, że w końcu działa i póki co zachowuje się deterministycznie q: […póki co…]

eN.

WebDav – Sharepoint na w2k8R2

Ponieważ już drugi raz zapomniałem – czas to sobie zapisać [*zapamiętać*]:

sharepoint nie korzysta z WebDav dostarczanego przez IIS – ma wbudowany własny mechanizm. w związq z tym nie trzeba instalować tego komponentu. co więcej – dla wersji x64, niewolno go instalować, ponieważ nawet jeśli jest wyłączony dla poszczególnych siteów, nie będzie działał komponent SP.

z emesowego Whitepaper – Understanding and Troubleshooting the SharePoint Explorer View:

WebDAV, IIS, and SharePoint

Many people are under the misconception that SharePoint uses the WebDAV functionality provided by IIS 6.0. Actually, SharePoint provides its own WebDAV implementation using the Stsfilt.dll ISAPI filter that is installed with both Windows SharePoint Services and SharePoint Portal Server. Enabling or disabling the WebDAV extension in IIS 6.0 has no effect on SharePoint functionality.

*UPDATE*

jest jeszcze jedna zabawa sprawa – jeśli site skonfigurowany jest *tylko* z SSL [require SSL] to przy próbie zmapowania dostaje się błąd ‘acc denied’. jeśli jest skonfigurowane jest dodatkowe dowiązanie [nie musi to być port 8o – ja wstawiłem 8o8] i odhaczy się ‘require SSL’ to polecenie “net use * https://sharepoint…” działa normalnie. gr8.

eN.

zarobki IT

polecam przeczytanie artu na webhosting – przedstawia średnie krajowe zarobki na różnych stanowiskach. dzięki temu można sobie mniej-wiecej sprawdzić jak bardzo jesteśmy niedoceniani (;

ja po zapoznaniu się z tymi liczbami dochodzę do wniosq, że IT w polsze jest potwornie niedofinansowane. największym szokiem są dla mnie stawki dla grafików – to po prostu śmiech na sali.

eN