konfiguracja exchange frontend z NLB. dla host, dwa IISy. musi byc oczywiscie HTTPS. konfigurowalem juz cos takiego kilka razy – nie spodziewalem sie problemow. tutaj konfiguracja jednak byla nieco odmienna – poniewaz w domenie nie ma RootCA. certyfikat ma byc qpiony w przyszlosci, wiec w celach tymczasowej konfiguracji postawilem virtualke z w2k3, na niej rootca, i na tym wyrzezbilem certyfikat…

…no i zaczely sie schody, poniewaz przy probie polaczenia via https dostawalem od przegladarki bardzo dziwny komunikat. w przypadq O komunikat przynajmniej odroznial sie od zwyklego ‘host unavaliable’ sugerujac jakis problem z certem, natomiast IE uparcie twierdzilo, ze hosta nie ma – sprawdz DNS. co za glupota.
sprawdzam konifguracje… wszystko hula. cert jest jak nalezy, port ok… pomyslalem, ze moze z jakiegos powodu zly rootca… robilem rozne rzeczy, w sumie kilka h, az w koncu znalazlem przyczyne – jak zwykle najciemniej pod latarnia. zaimportowany certyfikat z jakiegos powodu importowal sie bez klucza prywatnego.

zaimportowalem userowi [tu o dziwo dzialalo!], wyexportowalem z opcja ‘with private key’, nastepnie import dla maszyny… i hula!

Spread the love

Comments (1)

  1. kojn

    Odpowiedz

    REKLAMA ;) “swoimi osiągnięciami, możesz się również pochwalić na http://aim.altkom.pl” KONIEC RREKALMY… ja ostatnio straciłem 1,5 tygodnia, tylko dlatego, ze zachciało mi się w SQL Expressie zmienić język na PL. Zachciało mi się też o tej drobnostce zapomnieć. Efekt?! Brak rezultatów wyszukiwania fulltext. Obsługa błędów niestety kuleje

Zostaw komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Time limit is exhausted. Please reload CAPTCHA.