Ciekawa awaria – ni-stąd-ni-zowąd system zaczyna działać jakbym postawił Vista na 486. Nawet processexplorer zabierał 5o% procka na wyświetlenie informacji o procesach. Oczywiście najpierw grube testy: test pamięci, procka, AV… wszystko ok. Komp znów zaczyna działać normalnie. Po jakimś czasie sytuacja się powtarza – tym razem obiecałem sobie cierpliwość [duuuużo cierpliwości] i zaczynam weryfikować proces po procesie. Najbardziej podejrzane jest DPCs (Diferred Procedure Calls), które pożerało 8o% procka. Po przeczytaniu kilq artów, które miały podobne przyczyny – podejrzenie pada na jakiś zły sterownik…
Finalnie przyczyna okazuje się totalnie błaha i równie odległa – kot nadgryzł kabel zasilający, przy specyficznym wygięciu kabla elektronika lapa najwyraźniej weryfiqje parametry podawanego zasilania – i zamiast je odciąć lub coś zakomunikować, uderza w moduł zarządzania energią (Power Management). Uszkodzony moduł wysyła do urządzeń dziwne informacje, sqtqjące – w przypadq procesora (Mobile) przełączenie na tryb oszczędzania. Vista podczas startu [ok. 15min] w końcu bluescreenuje z komunikatem w stylu „INTERNAL_POWER”.

wnioski? nie wolno zapominać, że każdy soft działa na sprzęcie, i nie każdy błąd da się zdebugować za pomocą narzędzi systemowych. Łatwo można stracić wiele czasu jeśli zapomni się o tak podstawowej sprawie q:
drugi wniosek: potwornie dziwne zachowanie… jak się okazuje cała ta nowoczesna elektronika która ma zabezpieczać, może przyczynić się do uszkodzenia. Lap zachowuje się teraz dziwnie i mam wrażenie, że to jeszcze nie koniec problemów w zarządzaniem energią ):