Skip to Content

IT nieuczesane.
archive

> Daily Archives: 9 marca 2007

znowu bug na gronie – ROTFL

to ci dopiero – kiedy wszedlem do swojego profilu na gronie i wielce zdziwiony zobaczylem cudzy. zrobilem mala modyfikacje – dziala. moglem zrobic wszystko. oczywiscie sie wylogowalem z nadzieja, ze kiedy ktos trafi na moj zrobi to samo… tym razem rownie niezla jazdka – wlasnie postanowilem dodac fotke do galerii… wrzucilem ta:

a pojawila sie ta:

ROTFL – podoba mi sie to grono! szybciutko uploaduje nastepna! moze sie robiora? (;

SMTP isAlive timeout

„SMTP Virtual Server Instance 1 (EVS1): The IsAlive check for this resource failed.”
o dziwo informacji wygooglac mozna malo, a wszystkie, na ktore trafilem byly nietrafne. nikt, ale to zupelnie nikt nie podal najprostrzego z mozliwych scenariuszy – a jak wiadomo najciemniej jest pod latarnia.
scenariusz:
– rozgrzebany cluster
– czerwony event log
– po 3h walki eventlog zrobil sie bialy poza tym jednym wpisem – SMTP isAlive check failed.

rozwiazanie: okazalo sie, ze ktos w ustawieniach protokolu SMTP ustawil opcje ‚deny all except list below’ a lista zostala pusta. no i cluster myslal, ze smtp jest martwe.

bezoffice2k7

nowy office 2k7 to w pelni zoptymalizowany produkt. zainstalowanie ani-jednego-pliq officea zajmuje ponad 6ooMB. zainstalowanie jednego juz ponad 8ooMB.
oto screenshot z instalacji office po zaznaczeniu w ‚root’ ‚przy pierwszej instlacji’, oraz *wszystkich* komponentow na ‚nieinstaluj’. zainstalowanie samego outlooka to bagatela – 831MB!!!

polskie znaki w AD i DNS i nie tylko

kilka ciekawostek, ktore wyniknely z infrmacji od pstryka. otoz ciekawostka numer jeden – scenariusz:
– zaloz rekord DNS z polskim znakiem [np. ‚gdańsk’]
– teraz przy zakladaniu rekordu bez tego znaq [‚gdansk’] wywali blad, ze taki juz istnieje. niemniej po wejsciu do konsoli widac teraz juz dwa rekordy
– skasuj rekord z polskim znakiem [i tak go nie obsluguje – wpidy DNS dla znakow diakrytycznych wygladaja inaczej]
… no i wszystko ok – pomylkowo wpisany rekord usuniety… czy aby? po kilq minutach po skasowaniu rekord ‚gdańsk’ pojawia sie znow, sam z siebie! to ci niezly myk. o ile przetestowalem usuniecie go z linii polecen, przy pomocy ‚dnscmd /recorddelete’ wydaje sie usuwac go na stale.

powstaje jednak kilka pytan – czemu rekord po skasowaniu, wcale sie nie kasuje, czemu pomimo ze wywala ostrzezenie drugi rekord sie zaklada? czy sa traktowane jako jeden czy nie?
dodatkowo zaczalem przegrzebywac partycje aplikacji i… nie dotarlem do niej. spodziewalem sie, ze po uzyciu adsiedit’a bede mogl przejrzec strukture DNSu. nie udalo mi sie jej znalezc ani informacji jak sie do niej dostac [inaczej niz via ntdsutil, zeby skonfigurowac jej replikacje lub dnscmd, zeby modyfikowac wpisy]. ale gdzie fizycznie przechowywane sa wpisy z partycji aplikacyjnych? je ne sais pas.

jesli chodzi o polskie literki w AD to zachowuje sie o tyle bardziej deterministycznie, ze po zalozeniu usera np. ‚józek’ nie uda sie juz zalozyc [tym razem na prawde sie nie da] usera ‚jozek’. co wiecej, po zalozeniu np. ‚OU=łódź’ z linii polecen mozna dostac sie do tego na wszelkie sposoby i zawsze bedzie to ten sam obiekt – lodz, łódż, łodź…. zreszta prosze bardzo dowod:

set oDom=getObject("LDAP://RootDSE")
domDNS=oDom.dnshostname
namingContext=oDom.defaultNamingContext
set oCtx=GetObject("LDAP://"&namingContext)
set oOU=oCtx.create("OrganizationalUnit","OU=ŁÓDŹ")
oOU.description="jakiś tam opis ĄśćŹ"
oOU.setInfo
set oCtx=nothing 'unbind
set oOU=nothing 'destroy object
set oOU=getObject("LDAP://OU=LODZ,"&namingContext)
wscript.echo cstr(hex(err.number))&" "&oOU.description
set oOU=getObject("LDAP://OU=LÓDZ,"&namingContext)
wscript.echo cstr(hex(err.number))&" "&oOU.description
set oOU=getObject("LDAP://OU=LÓDŻ,"&namingContext)
wscript.echo cstr(hex(err.number))&" "&oOU.description

warto zwrocic uwage, ze na koncu jest Ż a nie Ź – a wiec wogole inny znak. dokonywana jest jakas automagiczna konwersja znakow. smieszne jest to, ze w interfersie te znaki widac.

wniosek – nie bez powodu nawet na blogu unikam polskich fontow. mialem z tym problemy nie raz i nie tylko pod windowsem [ilez to ja sie nakompilowalem, zeby miec polskie znaczki na konsoli!].

ps. inny stary bug z windows – jesli regionalsy SYSTEMOWE [czyli nie w profilu usera ale dla calego systemu] sa polskie i zalozy sie plik z polskim znaczkiem, to na kompie gdzie polskie regionalsy nie sa ustawione jest blad odczytu. a moze to bylo odwrotnie? (; nie pamietam, polskich znaczkow sie boje i unikam.